IRC Log Viewer » #firebreath » 2011-07-24

IRC Nick Time (GMT-7) Message
someone-noone 07:07 hello!
nullvalue 08:07 hey guys.. quick question bout installing on the Mac..
I've managed to create a dmg with an installer using the PackageMaker
is there any way that you know of to install the plugin without requiring a browser restart?
basically all the installer does is copy the file to /Library/Internet Plug-ins
linearray 08:07 not that i know of
and if there is one, it's browser-dependent
nullvalue 08:07 poo
im working with a Mac purist who believes it shouldn't be neccessary
linearray 08:07 so, there might be ways for specific browsers
nullvalue 08:07 lol
taxilian 08:07 nullvalue: you shouldn't need to restart the browser on mac to install a plugin
nullvalue 08:07 have any ideas? anything you could point me to, for Safari?
taxilian 08:07 I have never needed to
nullvalue 08:07 on the Mac?
taxilian 08:07 you just need to call navigator.plugins.refresh(false)
yeah
nullvalue 08:07 oh interesting! i'll try that
linearray 08:07 hm, that's not my experience with chrome
taxilian 08:07 but if you update it you'll need to change the name of the .plugin directory; you can't just replace the old one
linearray: I've been doing it for years
nullvalue 08:07 got it
taxilian 08:07 gotta run, good luck!
nullvalue 08:07 is navigator.plugins.refresh(false) supported in all browsers?
ok thanks
Sinisa 08:07 Hello everyone
hey amackera :-) Long time no see :-) Just to drop by, see if you guys are still alive
nullvalue 08:07 linearray: i've seen in Chrome on windows that it must have its own built-in way of refreshing after a plugin has been iinstalled - it seems to do it automatically when installing from the msi
but not the same case on mav..
mac
linearray 08:07 ok, seems like I didn't know about navigator.plugins.refresh(false)
that works for me :)
nullvalue 08:07 sweet im testing it now..
which browser did it work in for you?
linearray 08:07 chrome
it's curious... when you're used to doing things the same complicated way for ages, you automatically assume there's no better way :)
nullvalue 08:07 lol
where did you put that line of javascript?
linearray 08:07 JS console
nullvalue 08:07 ahh
linearray 08:07 just to test
nullvalue 08:07 oh sweet
it put it in body onload
it worked on the 2nd refrech
i'm going to try passing in (true)
ok that didn't help
so i'll need to put some kind of "click here when done" page in-between
but that works, my Mac purist friend should be happy
thanks guys!
jshanab_wcw 11:07 Anyone here play with SDL?
jshanab_wcw 12:07 I have a strange issue. plugin works in IE instead of FF. in FF the SDL library takes over the browsers very window, blocking the main thread and clearing the browser to black, but in IE the video is properly in the child window provided and events are not userpted. Is there a difference in how the browsers give the window handle in the AttachWindow call?
jshanab 17:07 BTW, Giving up on SDL-1.3 for a third time. It turns out that for it to work properly, the inti and destruct must be on the same thread, but if you use CreateWindowFrom() the handle we get, you cannot destroy the window, it blocks. if you don't destroy it, you can't SDLQuit() and that is a serious resource leak and crashes the next attempt to SDLInit(). WHen on different threads, I can fool...
...it, but only in IE. Still cannot get it stable and predictable. :-(
firing 19:07 Hey all! Need some help with an error I'm getting when I programmatically insert my plugin with javascript onto a page in Chrom extension.
when i call upon the plugin as plugin().myMethod(); I get a "Uncaught Error: Error calling method on NPObject"
any ideas why i'm getting this? Not much help on google
firing 23:07 Not sure if you all saw my question but here it is again in case any one can help out please :) :
Hey all! Need some help with an error I'm getting when I programmatically insert my plugin with javascript onto a page in Chrom extension. when i call upon the plugin as plugin().myMethod(); I get a "Uncaught Error: Error calling method on NPObject" any ideas why i'm getting this? Not much help on google