IRC Log Viewer » #firebreath » 2013-12-07

IRC Nick Time (GMT-7) Message
mkoch 12:12 hi
I have project started with FB1.5, then upgraded to 1.6. Now I have already 1.7 under it, but there is one thing I can't figure out why is happening
in the PluginConfig.cmake I have "SPlayer" for PLUGIN_NAME and "application/x-vnd.FBSPlayer" for FBSTRING_MIMEType
still, when I build it on Mac (mavericks), the name of the executable in the plugin bundle is not "SPlayer" but "npSPlayer"
and I can't figure out where does that "np" come from
and I can't figure out where does that "np" come from
unless I rename it, Safari doesn't even load the plugin
mkoch 13:12 taxilian: hi! do you have any idea about this one ^^ ?
taxilian 13:12 I know this was changed, but I don't know why Safari wouldn't load it
might have to do with your plist file?
might have to do with your plist file?
I don't understand why the naming change (which I think was done to fix some inconsistencies) would cause so much trouble; maybe someone should revert it.
mkoch 13:12 I see, thanks
kylehuff 13:12 I'll be building again in osx tonight or tomorrow, I will look into the issue and push out a fix
I know I run into this issue every time I build, but I work around it. this time I'll share the love.
mkoch 13:12 kylehuff: would be great, thanks. what's your workaround btw? simply renaming the executable when the build is complete?
kylehuff 13:12 I dont remember, and I'm not at home right now, so I cant look at my notes
I dont remember, and I'm not at home right now, so I cant look at my notes
mkoch 13:12 then you don't remember also which part of the config is responsible for that np prefix, I suspect, do you?